Laborationer

IPv6 Statisk routing

Samma konfigurationsprinciper som i IPv4, men det kräver att man kan skilja IPv6 adresstyper. Annars samma procedur. I detta exemplet ska vi koppla ihop fyra LAN och vi ska dirigera IPv6 datatrafik via statiska vägar. här nedan topologin vi ska arbeta med:

  • RA 1841 router + HWIC-2T
  • RB 1841 router + HWIC-2T
  • RC 2911 router + HWIC-2T
  • RD 2911 router + HWIC-2T
  • 2960 switch

Addresskonfigurationer

Jag börjar med att konfigurera länk efter länk: router RA och RB, därefter router RB och RC, fortsätter därefter med RC och RD.

Seriella Interface RA-RB

Router(config)# hostname RA
RA(config)# ipv6 unicast-routing

RA(config)# interface s0/0/0
RA(config-if)# no ip address
RA(config-if)# ipv6 address 2001:db8:beef:ff01::a/127
RA(config-if)# ipv6 enable
RA(config-if)# clock rate 2000000
RA(config-if)# no shut

Router(config)# hostname RB
RB(config)# ipv6 unicast-routing

RB(config)# interface s0/0/0
RB(config-if)# no ip address
RB(config-if)# ipv6 address 2001:db8:beef:ff01::b/127
RB(config-if)# ipv6 enable
RB(config-if)# no shut

Seriella Interface RB-RC

RB(config)# interface s0/0/1
RB(config-if)# no ip address
RB(config-if)# ipv6 address 2001:db8:beef:ff02::a/127
RB(config-if)# ipv6 enable
RB(config-if)# clock rate 2000000
RB(config-if)# no shut

Router(config)# hostname RC
RC(config)# ipv6 unicast-routing

RC(config)# interface s0/0/1
RC(config-if)# no ip address
RC(config-if)# ipv6 address 2001:db8:beef:ff02::b/127
RC(config-if)# ipv6 enable
RC(config-if)# no shut

Seriella Interface RC-RD

RC(config)# interface s0/0/0
RC(config-if)# no ip address
RC(config-if)# ipv6 address 2001:db8:beef:ff03::a/127
RC(config-if)# ipv6 enable
RC(config-if)# clock rate 2000000
RC(config-if)# no shut

Router(config)# hostname RD
RD(config)# ipv6 unicast-routing

RD(config)# interface s0/0/0
RD(config-if)# no ip address
RD(config-if)# ipv6 address 2001:db8:beef:ff03::b/127
RD(config-if)# ipv6 enable
RD(config)# no shut

Seriella Interface RD-RA

RD(config)# interface s0/0/1
RD(config-if)# no ip address
RD(config-if)# ipv6 address 2001:db8:beef:ff04::a/127
RD(config-if)# ipv6 enable
RD(config-if)# clock rate 2000000
RD(config)# no shut

RA(config)# interface s0/0/1
RA(config-if)# no ip address
RA(config-if)# ipv6 address 2001:db8:beef:ff04::b/127
RA(config-if)# ipv6 enable
RA(config)# no shut

LAN konfigurationer

RA(config)# interface fa0/0
RA(config-if)# no ip address
RA(config-if)# ipv6 address 2001:db8:beef:4::1/64
RA(config-if)# ipv6 enable
RA(config)# no shut

RB(config)# interface fa0/0
RB(config-if)# no ip address
RB(config-if)# ipv6 address 2001:db8:beef:3::1/64
RB(config-if)# ipv6 enable
RB(config)# no shut

RC(config)# interface g0/0
RC(config-if)# no ip address
RC(config-if)# ipv6 address 2001:db8:beef:2::1/64
RC(config-if)# ipv6 enable
RC(config-if)# no shut

RD(config)# interface g0/0
RD(config-if)# no ip address
RD(config-if)# ipv6 address 2001:db8:beef:1::1/64
R(config-if)# ipv6 enable
RD(config)# no shut

Routing

RA(config)# ipv6 route 2001:db8:beef:1::/64 2001:db8:beef:ff04::a
RA(config)# ipv6 route 2001:db8:beef:2::/64 2001:db8:beef:ff04::a
RA(config)# ipv6 route 2001:db8:beef:3::/64 2001:db8:beef:ff01::b

RB(config)# ipv6 route 2001:db8:beef:1::/64 2001:db8:beef:ff02::b
RB(config)# ipv6 route 2001:db8:beef:2::/64 2001:db8:beef:ff02::b
RB(config)# ipv6 route 2001:db8:beef:4::/64 2001:db8:beef:ff01::a

RC(config)# ipv6 route 2001:db8:beef:1::/64 2001:db8:beef:ff03::b
RC(config)# ipv6 route 2001:db8:beef:3::/64 2001:db8:beef:ff02::a
RC(config)# ipv6 route 2001:db8:beef:4::/64 2001:db8:beef:ff02::a

RD(config)# ipv6 route 2001:db8:beef:2::/64 2001:db8:beef:ff03::a
RD(config)# ipv6 route 2001:db8:beef:3::/64 2001:db8:beef:ff04::a
RD(config)# ipv6 route 2001:db8:beef:4::/64 2001:db8:beef:ff04::b

RIP för IPv6

RIP är ett distans-vektor routing-protokoll som använder antal hop som en routing metric. RIP är ett Interface Gateway Protocol (IGP) som oftast används i mindre nätverk. RIP för IPv6 är också vanligtvis refererad till som RIPng vilket är utformad för att stödja IPv6 och fungera på samma sätt som RIPv2 i IPv4. RIPng använder multicast adressen FF02 :: 9 som destinationsadress för RIP-uppdateringsmeddelande.

I det här konfigurationsexemplet är routrarna R1 och R2 anslutna via fast Ethernet interface. Loopback-adresser är konfigurerade för att generera nätverk. Alla interface är konfigurerade med IPv6-adresser.

Obs! Alla konfigurationer testas i en laboratoriemiljö på operativsystemet Cisco 1841 Router på Cisco IOS 12.4-versionen.

IPv6 adresskonfigurationer

Router 1

  • Router(config)# hostname R1
  • R1(config)# ipv6 unicast-routing
  • R1(config)# ipv6 cef

Loopback interface konfiguration

  • R1(config)# int lo 10
  • R1(config-if)# no ip address
  • R1(config-if)# ipv6 enable
  • R1(config-if)# ipv6 address 1111::1/128
  • R1(config-if)# ipv6 rip RIPng1 enable
  • R1(config)# int lo 20
  • R1(config-if)# no ip address
  • R1(config-if)# ipv6 enable
  • R1(config-if)# ipv6 address 2222::1/128
  • R1(config-if)# ipv6 rip RIPng1 enable

Fast Ethernet interface konfiguration

  • R1(config)# interface fa0/0
  • R1(config-if)# no ip address
  • R1(config-if)# ipv6 enable
  • R1(config-if)#ipv6 address 1011:11:11:11::1/64
  • R1(config-if)# ipv6 rip RIPng1 enable
  • R1(config-if)# no shutdown
  • R1(config-if)# end

Router 2

  • Router(config)# hostname R2
  • R2(config)# ipv6 unicast-routing
  • R2(config)# ipv6 cef

Loopback interface konfiguration

  • R2(config)# int lo 0
  • R2(config-if)# no ip address
  • R2(config-if)# ipv6 enable
  • R2(config-if)# ipv6 address 2011::1/128
  • R2(config-if)# ipv6 rip RIPng1 enable
  • R2(config)# int lo 1
  • R2(config-if)# no ip address
  • R2(config-if)# ipv6 enable
  • R2(config-if)# ipv6 address 2020::1/128
  • R2(config-if)# ipv6 rip RIPng1 enable
  • R2(config-if)# end

Fast Ethernet interface konfiguration

  • R2(config)# interface fa0/0
  • R2(config-if)# no ip address
  • R2(config-if)# ipv6 enable
  • R2(config-if)# ipv6 address 1011:11:11:11::2/64
  • R2(config-if)# ipv6 rip RIPng1 enable
  • R2(config-if)# no shutdown
  • R2(config-if)# end

Verifieringar

  • R1# show ipv6 int br
  • R1# show ipv6 route
  • R1# show ipv6 rip database
  • R1# ping 1011:11:11:11::2
  • R1# ping 2011::1
  • R1# ping 2020::1
  • R2# show ipv6 int br
  • R2# show ipv6 route
  • R1# show ipv6 rip database
  • R2# ping 1011:11:11:11::1
  • R2# ping 1111::1
  • R2# ping 2222::1

EIGRP för IPv6

EIGRP är en förbättrad version av routing-protokollet IGRP, utvecklad av Cisco. Det är ett distansvektor protokoll som bygger på Diffused Update Algorithm (DUAL) för att beräkna den kortaste vägen till en destination inom ett nätverk. EIGRP för IPv6 fungerar på samma sätt som EIGRP IPv4 där de kan konfigureras och hanteras separat.

Obs! Alla konfigurationer testas i en laboratoriemiljö på operativsystemet Cisco 1841 Router på Cisco IOS 12.4-versionen.

Tänk på följande:

  • IGRP för IPv6 konfigureras direkt på interfacet som ska fungera med IGRP.
  • Ett Interface kan konfigureras direkt med EIGRP för IPv6, utan att använda en global IPv6-adress. Det finns inget nätverksadress i EIGRP för IPv6.
  • Routerns ID måste konfigureras för en EIGRPv6 protokollinstans innan den kan köras.
  • EIGRP för IPv6 har en shutdown-funktion. Se till att routing-processen är i “no shut” -läge för att kunna köra protokollet.
  • Passiva interface behöver inte konfigureras med IPv6 adresser
  • DUAL algoritmen tillåter alla nätverksenheter involverade i topologin synkronisera ändringar med varandra,men inte till andra nätverksenheter som inte är involverade även om de finns i samma nät.
  • EIGRP ökar antal hop från 15 till 224
  • EIGRP routrar skickar inkrementella uppdateringar till närliggande och nätverks tillhörande routrar.
  • EIGRP aggregerar route automatiskt.

I detta exempel konfigureras två routrar (Rl och R2) med IPv6-adresser. Loopback-adresser tilldelas i båda routrarna, och de är konfigurerade för att vara i EIGRP1. EIGRPv6 är aktiverad per interface med det här kommandot: ipv6 eigrp as-nummer.

Kommando

Router(config)# ipv6 unicast-routing Aktiverar IPv6 paketöverföring.
Router(config-if)# ipv6 enable Aktiverar IPv6 processer i ett specifikt interface.
Router(config-if)# ipv6 router eigrp 1 Aktiverar EIGRP för IPv6 i ett specifikt interface. Nummer 1 i kommandot identifierar ett Autonomous system.
Router(config-if)# ipv6 eigrp bandwidth-percent eigrp 1 75 Specificerar i procent bandbredden som EIGRP får använda på något interface.
Router(config-router)# router-id 10.1.1.1 Aktiverar identifikation på en IPv6 router

IPv6 adresskonfigurationer

Router 1

  • Router(config)# hostname R1
  • R1(config)# ipv6 unicast-routing

LOOPBACK INTERFACE KONFIGURATION

  • R1(config)# int lo0
  • R1(config-if)# no ip address
  • R1(config-if)# ipv6 address 1010:ab8::/64 eui-64
  • R1(config-if)# ipv6 enable
  • R1(config-if)# ipv6 eigrp 1
  • R1(config-if)# int lo1
  • R1(config-if)# no ip address
  • R1(config-if)# ipv6 address 2020:ab8::/64 eui-64
  • R1(config-if)# ipv6 enable
  • R1(config-if)# ipv6 eigrp 1
  • R1(config-if)# int lo2
  • R1(config-if)# no ip address
  • R1(config-if)# ipv6 address 3030:ab8::/64 eui-64
  • R1(config-if)# ipv6 enable
  • R1(config-if)# ipv6 eigrp 1

SERIELL INTERFACE KONFIGURATION

  • R1(config-if)# int s0/0/0
  • R1(config-if)# no ip address
  • R1(config-if)# ipv6 address fe80::1 link-local
  • R1(config-if)# ipv6 address 2010:ab8::1/64
  • R1(config-if)# ipv6 enable
  • R1(config-if)# ipv6 eigrp 1
  • R1(config-if)# clock rate 2000000
  • R1(config-if)# ipv6 router eigrp 1
  • R1(config-rtr)# router-id 2.2.2.2
  • R1(config-if)# no shut